Error -2147467259

Applies to:  eMIMS Classic

Problem

“When opening eMIMS, user receives “Error -2147467259, you do not have correct permissions” Permission/Security issue.

Only apply this fix if you are not running Fred dispense link.

For Fred Dispense installation instructions please view our website www.mims.com.au and click Support.

Error2147467259

 

Cause

Windows 7 Permission/Security issue.

 

Fix1

  • Right Click on the eMIMS icon on the desktop and select Properties
  • Click on the “Compatibility” tab and check the option “Run this program as an administrator”
  • Click apply and close the window. eMIMS should work now
  • If this does not work, apply the fix below

 

Fix2

Remove standalone eMIMS

  • Insert the CD into the CD drive of the computer.
  • Go to the “Start” menu and open “My Computer” (or “Computer” in Windows7)
  • Double click on the CD folder named EMIMS
  • Look for the program(application) in the folder called“Setup.exe” and double click on it
  • When the Wizard starts select “Remove all”

Install server eMIMS

  • Go to the “Start” menu and open “My Computer” (or “Computer” in Windows7)
  • Look in the CD folder for ‘Server.exe’ and double click on it to run
  • Follow the prompts displayed during Setup, the installation should take about 10-15 minutes depending on your computer
  • Once the Wizard finishes copying the files, ensure you eject the CD
  • Some users may receive a message screen ‘This program might not have installed correctly’, if you do receive this message after running the install please click ‘This program installed correctly‘ option
  • Go to the “Start” menu and open “My Computer” (or “Computer” in Windows7)Navigate to the eMIMS folder on your Hard Drive (C:\)
  • Double click on “Setup.exe” file in the eMIMS folder on your Hard Drive (C:\)Running this program will make a “Start” menu entry, and Desktop shortcut
  • Some users may receive a message screen ‘This program might not have installed correctly’, if you do receive this message after running the install please click ‘This program installed correctly’ option.

You should now have no problems in running your eMIMS from your “Start”  Menu or Desktop icon

 

Additional Installations of eMIMS

If you require additional computers installed with eMIMS, either repeat the full process above on each computer or if they are on the same network follow the below steps.

  • Go to the “Start” menu and open “My Computer” (or “Computer” in Windows7)
  • Navigate to the eMIMS folder on the Server computer you have just installed
  • Double click on the “Setup.exe” file in the eMIMS folder
  • Running this program will make a “Start” menu entry, and Desktop shortcut
  • Some users may receive a message screen ‘This program might not have installed correctly’, if you do receive this message after running the install please click ‘This program installed correctly’ option